Brand new unit RS250 loud distortion noise

Hi there, I just received the HIFi Rose RS250 streamer yesterday, straight out from the box, I connected the power and went through the basic setup. When I plugged in my headphone to the unit without playing any music, all I can hear is the buzzing/distortion noise. Why is that? When I play music through Tidal, some quiet music like Piano solo, I can hear the buzzing/distortion mix with the music.

When playing through my speaker, its the same. This time I mute the music and turn the volume knob to the max, the distortion is loud from both speakers.

Did they send me a defective unit ?

What do I do now ?

I can see you are posting this all over the forum :grinning:. It should get @ROSELOA 's attention soon enough. Good luck!

As you know I am so excited yesterday when I received the box. But very disappointed with the buzzing / distortion noise from the headphone jack also through the speakers.

Hello @Ceddy ,

I’m sorry about the noise issue.
I sent you a message since I hope to check few things related to information about the ROSE device.

Would you check the message please?

How do you connect your device to the LAN ? Via W-LAN ? Try cable connection instead.
Does distortion disappear switching off W-LAN ?

I found the problem. The buzzing noise and the distortion sound is when I have the RS250 put close to my tube amp. I believe the powerful transformer is causing the RF noise from the RS250 , So at least I know I don’t have a defective unit, nothing related to the LAN port…etc. The unit is perfectly fine.

2 Likes