Beware of the remotecontrol 150B

If you use Rose 150B as a preamplifier be careful with the remotecontrol when changing volume. A couple of time it raises the volume to full output and it wont stop no matter what. It has a life of its own, i almost blow my speakers a couple of time. And it doesnt respond properly on some other command either.

that’s why I bought a preamplifier, unfortunately it shouldn’t be.

@Ieniemini1984 @svenake56

We apologize for any inconvenience caused.

Contact the distributor in the country where you purchased the RS150b, explain the symptoms, and receive a new remote control.

Thank you

My RS520 remote behaves exactly the same. You need to press the volume up or down only 2-3 times at a time and stop, then do it again; otherwise, it will stop only at the top level or bottom level.

Additionally, it loses Bluetooth connectivity once a week, and you have to re-pair it with the unit, which can be a bit annoying.

I had the same problem with the remote control for my RS520.
The fix is simple. Just keep rapidly clicking the volume + or - button multiple times until you reach the desired level. This prevents the volume automatically going to the highest or lowest level which, as you rightly say, could lead to speaker damage.
I’m grateful to my dealer for informing me of this “ workaround”.
It certainly worked for me and I hope it does for you too.

Hi, thanks but it still is a big mailfunction, a remotecontrol should do what ever commando you give it, fast or slow, if you are to slow pressning the buttons you may blow your speakers??? What kind of product is that???
Best regards Sven-Åke

I’ve had the opposite experience. If I press the + button too quickly, the volume begins to rapidly increase to 99.
This also occurs when using the Rose app on my smartphone. I am trying out using a volume limiter setting on Roon, and will post once I am brave enough to see if that will control a potentially damaging issue.

Hello @ROSEHAN ,

My 150B remote behaves the same as the above users @ svenake56.
I bought mine from AV1 Singapore but I use it Indonesia.

Another problem I notice is when I turn on my Gryphon amplifier my Rose unit suddenly died off.

Please kindly advice

Thank you

1 Like

@Martini @svenake56 @Harry

We apologize for any inconvenience caused.
There seems to be a software problem with the new, early silver remote control.
This is the part that cannot be modified remotely.
Contact the distributor in the country where you purchased the Rose device and request a remote control.

I apologize again.

@Popo

We apologize for any inconvenience caused.
Please check your message

Yesterday same behavior on my remote for the 520. Short presses work as workaround, but touching any longer, both up and down resulted in unstoppable rising of volume … Ouch, this will damage my loudspeakers ! Need a fix very soon on this.

There is a problem overall with this controlling volume - on the RA250 switching between speakers and headphones the volume stays at 99 nearly damaging my headphones and also my ears!! ROSE’s reply - it’s a hardware related problem!!! Since then …… radio silence :man_facepalming:t2::man_facepalming:t2::man_facepalming:t2:

Why are you still here?!

@HerrSchurz

We apologize for any inconvenience caused.
There seems to be a software problem with the new, early silver remote control.
This is the part that cannot be modified remotely.
Contact the distributor in the country where you purchased the Rose device and request a remote control.

I apologize again.

@Bruab

We apologize for the inconvenience.

Please answer a few questions.

  1. Do you use a fixed output value in the preout level setting?
  2. If I connect headphones with the volume set to 30 on the RS250, is the volume still set to 30?
  3. Did this symptom appear after the update?
  4. When you connect headphones to RS250, does the volume go up to 100? Or has it reached 100?

Hi Rosehan,

Find my answers below:

  1. Yes, I use fixed output set to 2200mV.

  2. It normally happens when I was listening via the speakers and then plug in the headphones. Most of the time the volume stays set at 99. It is absolutely imperative that I check the volume in order to prevent damage to the headphones and my ears!

  3. No, this happened from day one (Feb. 2023) and I’ve reported it several times.

  4. The volume is 99, it does not go slowly up. In general the switching between different inputs and outputs seems to be problematic as I still sometimes have to press the Apply button when I am sending the output to the speakers.

Hopefully this is helpful, but please ask more should you require further information.

Bruno

@Bruab

I have referred your information to the hardware team. It is said that when the RS250’s volume and headphones are connected, the volume is combined into one. The hardware team recommended using a larger preout volume setting value rather than 2200mV.

Hi Rosehan,

I am reasonably shocked by your reply. How well do you know the RA250? If you would know this streamer, you would know that 2200mV is the maximum I can set it to! I wish I could set it higher to be at the same level as my other sources.
Bruno

@Bruab

Of course, you can use it by setting the preout level setting to 2200mV, but when you connect headphones, you may encounter problems with the output being synced as is. Then I recommend that you use a preout level setting of 2200mV and use a low volume when connecting headphones.

Hi Rosehan,
I added a picture for your understanding. I can’t set the damn thing to a higher pre-out level!!!
Bruno