VU MODE problem

VU MODE - When you are playing native DSD the potentiometer arrow move minimally and is extremely right. Can you fix it?


Currently, VU meter can be used for music file (SSD, USB Storage, Network sharing) playback, Tidal, Radio, Podcast, and DLNA functions. (For reference, if Native or DOP Mode is used for DSD playback, the VU meter needle will not move)

Through future updates, we plan to support VU meter when using Rose Tube, Roon Ready, AirPlay, and CD Play.
In the near future, we will also try to support VU mode in Roon Ready. However, there are no plans for DSD yet.

As DSD is supported to play officially, but the VU meter is not work! should I say it is a bug?
When you say “However there are no plans for DSD yet” do you consider it is wrong.


When playing DSD, ROSE device have to put the sound source to DAC exactly as it is, without conversion. Therefore, the PCM information is not known and the VU cannot be accurately displayed.

In the input/output setting, if you look at the pre-output part setting, there is a DSD mode.
If you change the setting to DSD to PCM instead of the Native DSD option, VU can be operated based on PCM information.

Ha Ha DSD to PCM?, then do you think it is still DSD?
Interesting reply…!

Just if you are more focused on VU mode :slight_smile:

Hello , I have try as you said to change the DSD mode, the vu still pop in the red zone without moving too much.
What’s the solution?

Many thanks for the new updates on the VU metres, However many of us are experiencing that the needles are not moving or moving very slowly in one position -Will there be an update to fix this, many thanks.


Does all DSD files you have stay in red zone?

Also, how are you using your audio system?
RS150B > (USB) > DAC > AMP > SPK… ??

Hello Paul,

Thank you for your words. After checking the VU mode, we will do our best to reflect what you said in the next update.

1 Like

Thanking you for bringing out such a fantastic product and listening to what others are saying.

Hello, yes the same with Dsd and when i’m using Tidal , it’s work better when using via optical. Thanks