How to pair a Bluetooth remote control

Start from Step 0 for RS150.
Start from Step 1 for RS201.

Step 0 only for RS150) Connect the bluetooth dongle to the ‘BT dongle’ port of RS150.

Step 1) Look at the screen. Touch shape at the top of the screen.

Step 2) Turn on Bluetooth.

Step 3) Press and hold HOME button and MENU button(the one with three lines) on your bluetooth remote control for a while, until the red light stops blinking.

Step 4) Touch ‘Device Search’ on top of the screen.

Step 5) You will see ‘ROSE RCU’ under ‘Scanned device’. Touch ‘ROSE RCU’.

Step 6) You will see ‘ROSE RCU’ under ‘Paired Devices’. Touch ‘ROSE RCU’.

Step 7) If ‘ROSE RCU’ turns gold, that’s it.

If you still don’t get it, please check the video in this link.
The video is in Korean, but it’s the same.

1 Like

Dear community!
I would like to notice, that in manual of new RS250 is not mentioned how to pair your bluetooth remote.

In addition, remote from RS301 looks different. There’s no home and options button. How to pair this one?

Thank you for any reply!
PM

Hello, @4HIFI

  1. We added how to pair BT remote control for RS250 later, sorry about that.
  2. Can you show me the photo of the remote for RS301? I guess you received an IR remote control.
    IR remote works for RS350.

Thank you for your reply.

1.It is OK if you know that.
2.Yeah, right. Our fault, someone made a mistake bringing me wrong remote :slight_smile:

Thank you!

Hi,
Yesterday I followed the instructions above to connect my remote to my RS150. It went gold and worked.

Today I see it is under ‘Paired devices’ but in white and it does not work anymore. I pushed on it and a searching circle appears but disappears without changing something. Turning Bluetooth off and back on does not change something either.

I use ethernet cable, so I know the Wifi is disabled but Bluetooth should remain active, right? Furthermore have no problems to control the RS150 via the Rose Connect app on my iPhone.

Hello @Dopo ,

You are right, the remote should work regardless of WIFI. The Bluetooth remote only depends on BT dongle connected to the right USB port, and Bluetooth ‘ON’.

Would touch the ‘ROSE RCU’ for few seconds and delete it?
Turn off the bluetooth and turn it on again.
Please try to do paring again.

Thank you,

Hi @ROSELOA ,

Yes, me again :slight_smile:

The only solution was to unpair and delete the RCU, to disable Bluetooth and physically remove and re-insert the dongle on the back. I tried first without the physical manipulation but did not receive a gold name (cfr. step 7). Let’s see how long it remains this time.

ROSE RCU connecting Problem with RS250.

I can’t pair my ROSE 250 with ROSE RCU because of ‘an incorrect PIN or passkey’ problem.

Please help.

Hello,

Please check the message I sent you.

Thank you.